Melhore a performance do Ubuntu com zRam

Melhore a performance do Ubuntu com zRam

Apesar do Ubuntu ser um sistema bastante rápido out of the box, não consigo deixar de notar que quando é hora de usar a memória virtual (SWAP), a performance cai demais. Aparentemente, não fui o único a notar isto.

Sergey Davidoff, desenvolvedor da distro baseada no Ubuntu, ElementaryOS, na tentativa de otimizar o gerenciamento de memória da distro, encontrou um projeto chamado compcache. O compcache foi reescrito e otimizado, surgindo então o zRam.

zRam aumenta a performance ao evitar a paginação de disco usando um dispositivo de bloco comprimido na RAM, que fica responsável pela paginação, até quando for necessário usar o espaço swap no disco rígido. Em outras palavras, ele usa esse dispositivo de bloco comprimido na memória RAM para paginação ao invés de usar primeiro a paginação em disco propriamente dita (obrigado Tiago!).

A performance ganha com este tipo de memória virtual é considerável. Para termos de comparação, Sergey disse que rodou o gerenciamento em uma máquina com 1GB de memória RAM e quando a memória física se esgotou, o sistema continuou funcionando sem slowdowns, como se nada tivesse acontecido! Já se estivesse usando SWAP, as travadas constantes seriam um problema.

Isso é perfeito para netbooks, tablets, velhos computadores e máquinas virtuais. Mas é claro, você também pode usar no seu próprio sistema e comprovar os resultados.

Instalando zRam no Ubuntu

Para nossa sorte, Sergey empacotou tudo e criou um PPA para o Ubuntu 11.04 e Ubuntu 11.10. Para adicionar o repositório e fazer a instalação, basta abrir um terminal e copiar/colar os comandos abaixo.

sudo add-apt-repository ppa:shnatsel/zram && sudo apt-get update && sudo apt-get install zramswap-enabler -y

Pronto, tudo está funcionando agora. Recomendo reiniciar o computador por precaução :)

EDITADO: Para os usuários tendo problemas para ativar o suporte a zRam no Ubuntu, criei um post ensinando como corrigir o problema Resolvendo o problema do zRam no Ubuntu 11.10.

Minha máquina tem 4GB de RAM DDR3 e a melhoria de performance foi perceptível. Não tão grande, mas perceptível, principalmente nas minhas máquinas virtuais.

E você, conseguiu um ganho em performance com nosso dica? Deixe seu comentário abaixo! Adoro saber que ajudei alguém :)

E não esqueça de participar do nosso sorteio de natal atrasado! Temos itens oficiais Ubuntu lá, além de camisetas Vida de ProgramadorVida de Suporte e Red Bug! E claro, siga o blog Ubuntu-BR-SC no Twittercurta nossa página no Facebook abaixo e assine nosso Feed RSS :)

Assine nossa newsletter!

Quer receber as novidades mais recentes do Ubuntu na sua caixa de entrada? Informe seu e-mail e clique em Assinar.

  • Assine o feed RSS
  • Siga o Ubuntu-BR-SC no Twitter
  • Curta o Ubuntu-BR-SC no Facebook
  • Ubuntu-BR-SC no Google+
  • Canal do Ubuntu-BR-SC no YouTube


  • Michel Wilhelm

    Aqui no Oneric não funcionou =/
    Dá erro ao iniciar o processo. Mais alguém?

    • http://www.ubuntubrsc.com/ Julian Fernandes

      Qual o erro que aparece Michel?

  • http://mrnet.in/ Michel Wilhelm

    Aqui no Oneric não funcionou =/
    Dá erro ao iniciar o processo. Mais alguém?

    • http://www.ubuntubrsc.com/ Julian Fernandes

      Qual o erro que aparece Michel?

  • Michel Wilhelm

    Aqui no Oneric não funcionou =/
    Dá erro ao iniciar o processo. Mais alguém?

    • http://www.ubuntubrsc.com/ Julian Fernandes

      Qual o erro que aparece Michel?

  • Olnei Augusto Araujo

    Aqui, em um netbook Asus deu este erro :
    Configurando zramswap-enabler (0.2.1-0~12~oneiric1) …
    start: Job failed to start
    invoke-rc.d: initscript zramswap, action “start” failed.
    dpkg: erro processando zramswap-enabler (–configure):
     sub-processo script post-installation instalado retornou estado de saída de erro 1
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    olnei@olnei-netbook:~$

    • Pfornellas

      Aqui dá o mesmo erro. O meu ubuntu é 64, será que é isso?

      • http://www.ubuntubrsc.com/ Julian Fernandes

        Vocês dois estão usando o kernel 3.2? Se for isso, usem a dica que passei nos comentários abaixo, editando o PPA.

        Tecnicamente o kernel 3.2 é do Ubuntu 12.04, então se você tiver usando o kernel 3.2 no Ubuntu 11.10, precisará mudar o PPA para o PPA do precise.

        Vou fazer um tutorial sobre o assunto amanhã :)

        • pfornellas

          Realmente estou usando 3.2 quando editei o ppa para precise deu tudo certo.

          • http://www.ubuntubrsc.com/ Julian Fernandes

            Opa, fico feliz que tenha ajudado Pfornellas :)

          • Jeffersonpgodoy

            Boa noite Julian!
            Tenho pouco tempo de Linux, apanho muito do Ubuntu, mas to gostando muito de usar.
            Gostei da dica, mas infelizmente meu ubuntu e de todos na empresa é o 10.04
            Não tem jeito msm de instalar o zRam nessa versão?
            Um abraço e parabéns pela dica.

          • http://www.ubuntubrsc.com/ Julian Fernandes

            Qual o Kernel utilizado atualmente no 10.04, @c9b417bd0d99a471ccce804f2ba7f688:disqus?
            Apesar do PPA só oferecer suporte ao Ubuntu 11.04 até 12.04, se o kernel utilizado for mais atualizado que o 2.6.37.1, pode-se usar o .deb: https://launchpad.net/~shnatsel/+archive/zram/+files/zramswap-enabler_0.2.1-0~12~oneiric1_all.deb

          • @Jeffersonpgodoy

            Meu kernel é o “2.6.32-41-generic” será que funciona? Ou melhor, posso atualizar para o kernel 3.4?
            Obrigado pela atenção.

          • http://www.ubuntubrsc.com/ Julian Fernandes

            Olá @c9b417bd0d99a471ccce804f2ba7f688:disqus,
            Se quiser tentar, terá que fazer por sua conta e risco. Não mexo no Ubuntu 10.04 faz uns bons anos hehe

  • Olnei Augusto Araujo

    Aqui, em um netbook Asus deu este erro :
    Configurando zramswap-enabler (0.2.1-0~12~oneiric1) …
    start: Job failed to start
    invoke-rc.d: initscript zramswap, action “start” failed.
    dpkg: erro processando zramswap-enabler (–configure):
     sub-processo script post-installation instalado retornou estado de saída de erro 1
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    olnei@olnei-netbook:~$

    • Pfornellas

      Aqui dá o mesmo erro. O meu ubuntu é 64, será que é isso?

      • http://www.ubuntubrsc.com/ Julian Fernandes

        Vocês dois estão usando o kernel 3.2? Se for isso, usem a dica que passei nos comentários abaixo, editando o PPA.

        Tecnicamente o kernel 3.2 é do Ubuntu 12.04, então se você tiver usando o kernel 3.2 no Ubuntu 11.10, precisará mudar o PPA para o PPA do precise.

        Vou fazer um tutorial sobre o assunto amanhã :)

        • pfornellas

          Realmente estou usando 3.2 quando editei o ppa para precise deu tudo certo.

          • http://www.ubuntubrsc.com/ Julian Fernandes

            Opa, fico feliz que tenha ajudado Pfornellas :)

  • Olnei Augusto Araujo

    Aqui, em um netbook Asus deu este erro :
    Configurando zramswap-enabler (0.2.1-0~12~oneiric1) …
    start: Job failed to start
    invoke-rc.d: initscript zramswap, action “start” failed.
    dpkg: erro processando zramswap-enabler (–configure):
     sub-processo script post-installation instalado retornou estado de saída de erro 1
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    olnei@olnei-netbook:~$

    • Pfornellas

      Aqui dá o mesmo erro. O meu ubuntu é 64, será que é isso?

      • http://www.ubuntubrsc.com/ Julian Fernandes

        Vocês dois estão usando o kernel 3.2? Se for isso, usem a dica que passei nos comentários abaixo, editando o PPA.

        Tecnicamente o kernel 3.2 é do Ubuntu 12.04, então se você tiver usando o kernel 3.2 no Ubuntu 11.10, precisará mudar o PPA para o PPA do precise.

        Vou fazer um tutorial sobre o assunto amanhã :)

        • pfornellas

          Realmente estou usando 3.2 quando editei o ppa para precise deu tudo certo.

          • http://www.ubuntubrsc.com/ Julian Fernandes

            Opa, fico feliz que tenha ajudado Pfornellas :)

  • Olnei Augusto Araujo

    Dei o comando  “sudo dpkg –configure -a” e, aparentemente, foi resolvido. Pelo menos, o aplicativo aparece como instalado.

    • http://www.ubuntubrsc.com/ Julian Fernandes

      Se estiver rodando o kernel 3.2 (que tecnicamente seria do Precise), terá que mudar o PPA.

      Se estiver no Oneiric por exemplo, terá que editar a lista de repositórios e dizer ao PPA utilizar a versão para o Precise.

  • Olnei Augusto Araujo

    Dei o comando  “sudo dpkg –configure -a” e, aparentemente, foi resolvido. Pelo menos, o aplicativo aparece como instalado.

    • http://www.ubuntubrsc.com/ Julian Fernandes

      Se estiver rodando o kernel 3.2 (que tecnicamente seria do Precise), terá que mudar o PPA.

      Se estiver no Oneiric por exemplo, terá que editar a lista de repositórios e dizer ao PPA utilizar a versão para o Precise.

      • Rogerio Torres

        Julian  sera que funciona no ubuntu 10.04?

        • http://www.ubuntubrsc.com/ Julian Fernandes

          Apenas do 11.04 em diante Rogério :/

          • Marden laairoy Correia de Oliv

            Estou obtendo o mesmo erro do Olnei, uso Xubuntu 11.10, Kenel 3.2.

            O comando ”sudo dpkg –configure -a” não resolveu o problema.

          • http://www.ubuntubrsc.com/ Julian Fernandes

            Olá Marden,
            Como o kernel 3.2 é tecnicamente do Ubuntu 12.04, você precisa editar sua lista de repositórios e no repositório PPA, mudar o “oneiric” pra “precise”.

          • Marden laairoy Correia de Oliv

            Merden é tenso.
            Obrigado pela dica, instalou normalmente, agora é só testar.

          • http://www.ubuntubrsc.com/ Julian Fernandes

            Opa… é o que acontece quando se fica horas demais acordado sem descanso :S
            Já corrigi o erro, desculpe.

            Fico feliz por ter funcionado :)

  • Olnei Augusto Araujo

    Dei o comando  “sudo dpkg –configure -a” e, aparentemente, foi resolvido. Pelo menos, o aplicativo aparece como instalado.

    • http://www.ubuntubrsc.com/ Julian Fernandes

      Se estiver rodando o kernel 3.2 (que tecnicamente seria do Precise), terá que mudar o PPA.

      Se estiver no Oneiric por exemplo, terá que editar a lista de repositórios e dizer ao PPA utilizar a versão para o Precise.

  • Rogerio Torres

    Julian  sera que funciona no ubuntu 10.04?

    • http://www.ubuntubrsc.com/ Julian Fernandes

      Apenas do 11.04 em diante Rogério :/

  • Rogerio Torres

    Julian  sera que funciona no ubuntu 10.04?

    • http://www.ubuntubrsc.com/ Julian Fernandes

      Apenas do 11.04 em diante Rogério :/

  • Marden laairoy Correia de Oliv

    Estou obtendo o mesmo erro do Olnei, uso Xubuntu 11.10, Kenel 3.2.

    O comando ”sudo dpkg –configure -a” não resolveu o problema.

    • http://www.ubuntubrsc.com/ Julian Fernandes

      Olá Marden,
      Como o kernel 3.2 é tecnicamente do Ubuntu 12.04, você precisa editar sua lista de repositórios e no repositório PPA, mudar o “oneiric” pra “precise”.

      • Marden laairoy Correia de Oliv

        Merden é tenso.
        Obrigado pela dica, instalou normalmente, agora é só testar.

        • http://www.ubuntubrsc.com/ Julian Fernandes

          Opa… é o que acontece quando se fica horas demais acordado sem descanso :S
          Já corrigi o erro, desculpe.

          Fico feliz por ter funcionado :)

      • Marden laairoy Correia de Oliv

        Merden é tenso.
        Obrigado pela dica, instalou normalmente, agora é só testar.

  • Marden laairoy Correia de Oliv

    Estou obtendo o mesmo erro do Olnei, uso Xubuntu 11.10, Kenel 3.2.

    O comando ”sudo dpkg –configure -a” não resolveu o problema.

    • http://www.ubuntubrsc.com/ Julian Fernandes

      Olá Marden,
      Como o kernel 3.2 é tecnicamente do Ubuntu 12.04, você precisa editar sua lista de repositórios e no repositório PPA, mudar o “oneiric” pra “precise”.

      • Marden laairoy Correia de Oliv

        Merden é tenso.
        Obrigado pela dica, instalou normalmente, agora é só testar.

        • http://www.ubuntubrsc.com/ Julian Fernandes

          Opa… é o que acontece quando se fica horas demais acordado sem descanso :S
          Já corrigi o erro, desculpe.

          Fico feliz por ter funcionado :)

      • Marden laairoy Correia de Oliv

        Merden é tenso.
        Obrigado pela dica, instalou normalmente, agora é só testar.

  • http://www.facebook.com/profile.php?id=100000331818890 Jonathan Siqueira Silva

    Acho que não instalou aqui manolos, apareceu isto no terminal  http://i.imgur.com/RxrBl.png , me ajudem ;D

    • http://www.ubuntubrsc.com/ Julian Fernandes

      Na verdade seu problema é que ainda tem o CD do Ubuntu como repositório.

      Aperte a tecla (aquela com o logo do Windows ou Ubuntu) e digita “canais de software”.
      Na aba “outros softwares”, desmarque o CD Ubuntu 11.10 que está lá. Ai é só digitar o comando abaixo no terminal:

      sudo apt-get update && sudo apt-get install zramswap-enabler -y

      Espero ter ajudado :)

  • http://www.facebook.com/profile.php?id=100000331818890 Jonathan Siqueira Silva

    Acho que não instalou aqui manolos, apareceu isto no terminal  http://i.imgur.com/RxrBl.png , me ajudem ;D

    • http://www.ubuntubrsc.com/ Julian Fernandes

      Na verdade seu problema é que ainda tem o CD do Ubuntu como repositório.

      Aperte a tecla (aquela com o logo do Windows ou Ubuntu) e digita “canais de software”.
      Na aba “outros softwares”, desmarque o CD Ubuntu 11.10 que está lá. Ai é só digitar o comando abaixo no terminal:

      sudo apt-get update && sudo apt-get install zramswap-enabler -y

      Espero ter ajudado :)

      • Willian

        “Instalei” no Xubuntu rodando em um Celeron 3Ghz com 1GB de ram, parece que deu uma melhorada.. 

    • André

      Estou usando um pc “pré-lixo” como 512 de memoria ram, mas com compartilhamento de memoria, então ele só tem 488 de ram, será q melhora alguma coisa com o zRam? se alguém puder me ajudar e responder, vou ficar feliz;)

      • http://www.ubuntubrsc.com/ Julian Fernandes

        Com certeza iria te ajudar André :)

        Quando a memória física acabar, o zRam irá tomar cuidado do resto.

        • Almeidaufpb

          Oi Julian, boa noite.
          Fiz o procedimento do “precise”, consegui alterar tranquilo mas ainda assim tem um erro no terminal. Segue em anexo.
          Obrigada

          • http://www.ubuntubrsc.com/ Julian Fernandes

            Olá @3ca2371bb544089b3355880cd606b22c:disqus,
            O PPA que você está usando para o software Wallch está retornando um erro 404. Apague-o e você poderá ativar o zRam tranquilamente (:

          • Almeidaufpb

             Boa tarde Julian,
            Estou “nova” no Ubuntu, então ainda tenho algumas dificuldades. O PPA que vc disse para apagar é do Wallch(que eu tinha instalado no net mas apaguei), fiz o procedimento pelo “canais de software” na aba “outro software” removi o wallch.
            Depois abri o terminal e refiz o procedimento para instalar o Zram. Ainda deu um erro, que coloquei em anexo.
            Obrigada pela atenção!!
            Fabiana

  • http://www.facebook.com/profile.php?id=100000331818890 Jonathan Siqueira Silva

    Acho que não instalou aqui manolos, apareceu isto no terminal  http://i.imgur.com/RxrBl.png , me ajudem ;D

    • http://www.ubuntubrsc.com/ Julian Fernandes

      Na verdade seu problema é que ainda tem o CD do Ubuntu como repositório.

      Aperte a tecla (aquela com o logo do Windows ou Ubuntu) e digita “canais de software”.
      Na aba “outros softwares”, desmarque o CD Ubuntu 11.10 que está lá. Ai é só digitar o comando abaixo no terminal:

      sudo apt-get update && sudo apt-get install zramswap-enabler -y

      Espero ter ajudado :)

    • André

      Estou usando um pc “pré-lixo” como 512 de memoria ram, mas com compartilhamento de memoria, então ele só tem 488 de ram, será q melhora alguma coisa com o zRam? se alguém puder me ajudar e responder, vou ficar feliz;)

      • http://www.ubuntubrsc.com/ Julian Fernandes

        Com certeza iria te ajudar André :)

        Quando a memória física acabar, o zRam irá tomar cuidado do resto.

        • Jeffersonpgodoy

          Boa noite Julian!
          Tenho pouco tempo de Linux, apanho muito do Ubuntu, mas to gostando muito de usar.
          Gostei da dica, mas infelizmente meu ubuntu e de todos na empresa é o 10.04
          Não tem jeito msm de instalar o zRam nessa versão?
          Um abraço e parabéns pela dica.

          • http://www.ubuntubrsc.com/ Julian Fernandes

            Qual o Kernel utilizado atualmente no 10.04, @c9b417bd0d99a471ccce804f2ba7f688:disqus?
            Apesar do PPA só oferecer suporte ao Ubuntu 11.04 até 12.04, se o kernel utilizado for mais atualizado que o 2.6.37.1, pode-se usar o .deb: https://launchpad.net/~shnatsel/+archive/zram/+files/zramswap-enabler_0.2.1-0~12~oneiric1_all.deb

          • @Jeffersonpgodoy

            Meu kernel é o “2.6.32-41-generic” será que funciona? Ou melhor, posso atualizar para o kernel 3.4?
            Obrigado pela atenção.

          • http://www.ubuntubrsc.com/ Julian Fernandes

            Olá @c9b417bd0d99a471ccce804f2ba7f688:disqus,
            Se quiser tentar, terá que fazer por sua conta e risco. Não mexo no Ubuntu 10.04 faz uns bons anos hehe

  • Willian

    “Instalei” no Xubuntu rodando em um Celeron 3Ghz com 1GB de ram, parece que deu uma melhorada.. 

  • Willian

    “Instalei” no Xubuntu rodando em um Celeron 3Ghz com 1GB de ram, parece que deu uma melhorada.. 

  • André

    Estou usando um pc “pré-lixo” como 512 de memoria ram, mas com compartilhamento de memoria, então ele só tem 488 de ram, será q melhora alguma coisa com o zRam? se alguém puder me ajudar e responder, vou ficar feliz;)

    • http://www.ubuntubrsc.com/ Julian Fernandes

      Com certeza iria te ajudar André :)

      Quando a memória física acabar, o zRam irá tomar cuidado do resto.

  • Jeffersonpgodoy

    Boa noite Julian!
    Tenho pouco tempo de Linux, apanho muito do Ubuntu, mas to gostando muito de usar.
    Gostei da dica, mas infelizmente meu ubuntu e de todos na empresa é o 10.04
    Não tem jeito msm de instalar o zRam nessa versão?
    Um abraço e parabéns pela dica.

    • http://www.ubuntubrsc.com/ Julian Fernandes

      Qual o Kernel utilizado atualmente no 10.04, @c9b417bd0d99a471ccce804f2ba7f688:disqus?
      Apesar do PPA só oferecer suporte ao Ubuntu 11.04 até 12.04, se o kernel utilizado for mais atualizado que o 2.6.37.1, pode-se usar o .deb: https://launchpad.net/~shnatsel/+archive/zram/+files/zramswap-enabler_0.2.1-0~12~oneiric1_all.deb

      • @Jeffersonpgodoy

        Meu kernel é o “2.6.32-41-generic” será que funciona? Ou melhor, posso atualizar para o kernel 3.4?
        Obrigado pela atenção.

        • http://www.ubuntubrsc.com/ Julian Fernandes

          Olá @c9b417bd0d99a471ccce804f2ba7f688:disqus,
          Se quiser tentar, terá que fazer por sua conta e risco. Não mexo no Ubuntu 10.04 faz uns bons anos hehe

  • Almeidaufpb

    Oi Julian, boa noite.
    Fiz o procedimento do “precise”, consegui alterar tranquilo mas ainda assim tem um erro no terminal. Segue em anexo.
    Obrigada

    • http://www.ubuntubrsc.com/ Julian Fernandes

      Olá @3ca2371bb544089b3355880cd606b22c:disqus,
      O PPA que você está usando para o software Wallch está retornando um erro 404. Apague-o e você poderá ativar o zRam tranquilamente (:

      • Almeidaufpb

         Boa tarde Julian,
        Estou “nova” no Ubuntu, então ainda tenho algumas dificuldades. O PPA que vc disse para apagar é do Wallch(que eu tinha instalado no net mas apaguei), fiz o procedimento pelo “canais de software” na aba “outro software” removi o wallch.
        Depois abri o terminal e refiz o procedimento para instalar o Zram. Ainda deu um erro, que coloquei em anexo.
        Obrigada pela atenção!!
        Fabiana

        • http://www.ubuntubrsc.com/ Julian Fernandes

          Olá @3ca2371bb544089b3355880cd606b22c:disqus,
          Tente rodar o seguinte comando: apt-get autoclean && apt-get clean
          Nunca tive esse erro, mas pelo o que andei vendo em uma pesquisa aqui, acontece quando a partição do sistema está cheia. Tente rodar o comando que lhe falei e usar o tutorial novamente (:

          • Almeidaufpb

             Olá Julian boa noite,
            obrigada pela ajuda.
            O resultado desse comando foi esse

            “fabiana@fabiana-O-E-M:~$ apt-get autoclean && apt-get clean
            E: Não foi possível abrir arquivo de trava /var/cache/apt/archives/lock – open (13: Permissão negada)
            E: Impossível criar trava no diretório de download
            fabiana@fabiana-O-E-M:~$ ”

            Fiz o procedimento do tutorial e acho que deu errado também. Anexei a captura da tela pra vc ver!

            Obrigada!

          • http://www.ubuntubrsc.com/ Julian Fernandes

            Olá @3ca2371bb544089b3355880cd606b22c:disqus,
            Desculpe, no comando que lhe passei esqueci de adicionar o sudo. Então fica assim:

            sudo apt-get autoclean && sudo apt-get clean

          • Almeidaufpb

             Opa!! Valeu.
            No 1º comando deu isso

            fabiana@fabiana-O-E-M:~$ sudo apt-get autoclean && sudo apt-get clean
            [sudo] password for fabiana:
            Lendo listas de pacotes… Pronto
            Construindo árvore de dependências      
            Lendo informação de estado… Pronto

            Depois do comando pra instalação do Zram, continuou o erro, te mandei em tela.

          • http://www.ubuntubrsc.com/ Julian Fernandes

            Olá @3ca2371bb544089b3355880cd606b22c:disqus, desculpe a demora. De cabeça consigo pensar em mais duas tentativas de solução.

            A primeira seria fazer os procedimentos descritos nesse post: http://www.ubuntubrsc.com/resolvendo-problema-zram-ubuntu-11-10.html
            Apesar do erro ser diferente, um usuário reportou o mesmo problema que o seu e deu certo.

            Outra possível solução seria fazer o download do arquivo .deb diretamente do Launchpad: https://launchpad.net/~shnatsel/+archive/zram/+files/zramswap-enabler_0.2.1-0~12~oneiric1_all.deb

            Pra instalar um arquivo .deb, basta dar dois cliques nele e depois clicar em “Instalar” (:

          • Almeidaufpb

             Ô Querido, muito obrigada pela atenção mas não deu certo. Ele está como instalado mas não consigo abrir a interface. Talvez, como sou nova no Ubuntu, eu esteja fazendo algo errado…

            Boa Páscoa pra vc e família!!

            Fabiana

          • http://www.ubuntubrsc.com/ Julian Fernandes

            Estranho @3ca2371bb544089b3355880cd606b22c:disqus,
            Bom, o Ubuntu 12.04 está quase ai e já temos uma melhoria de performance incrível.

            Feliz páscoa atrasada btw :)

  • Almeidaufpb

    Oi Julian, boa noite.
    Fiz o procedimento do “precise”, consegui alterar tranquilo mas ainda assim tem um erro no terminal. Segue em anexo.
    Obrigada

    • http://www.ubuntubrsc.com/ Julian Fernandes

      Olá @3ca2371bb544089b3355880cd606b22c:disqus,
      O PPA que você está usando para o software Wallch está retornando um erro 404. Apague-o e você poderá ativar o zRam tranquilamente (:

      • Almeidaufpb

         Boa tarde Julian,
        Estou “nova” no Ubuntu, então ainda tenho algumas dificuldades. O PPA que vc disse para apagar é do Wallch(que eu tinha instalado no net mas apaguei), fiz o procedimento pelo “canais de software” na aba “outro software” removi o wallch.
        Depois abri o terminal e refiz o procedimento para instalar o Zram. Ainda deu um erro, que coloquei em anexo.
        Obrigada pela atenção!!
        Fabiana

        • http://www.ubuntubrsc.com/ Julian Fernandes

          Olá @3ca2371bb544089b3355880cd606b22c:disqus,
          Tente rodar o seguinte comando: apt-get autoclean && apt-get clean
          Nunca tive esse erro, mas pelo o que andei vendo em uma pesquisa aqui, acontece quando a partição do sistema está cheia. Tente rodar o comando que lhe falei e usar o tutorial novamente (:

          • Almeidaufpb

             Olá Julian boa noite,
            obrigada pela ajuda.
            O resultado desse comando foi esse

            “fabiana@fabiana-O-E-M:~$ apt-get autoclean && apt-get clean
            E: Não foi possível abrir arquivo de trava /var/cache/apt/archives/lock – open (13: Permissão negada)
            E: Impossível criar trava no diretório de download
            fabiana@fabiana-O-E-M:~$ ”

            Fiz o procedimento do tutorial e acho que deu errado também. Anexei a captura da tela pra vc ver!

            Obrigada!

          • http://www.ubuntubrsc.com/ Julian Fernandes

            Olá @3ca2371bb544089b3355880cd606b22c:disqus,
            Desculpe, no comando que lhe passei esqueci de adicionar o sudo. Então fica assim:

            sudo apt-get autoclean && sudo apt-get clean

          • Almeidaufpb

             Opa!! Valeu.
            No 1º comando deu isso

            fabiana@fabiana-O-E-M:~$ sudo apt-get autoclean && sudo apt-get clean
            [sudo] password for fabiana:
            Lendo listas de pacotes… Pronto
            Construindo árvore de dependências      
            Lendo informação de estado… Pronto

            Depois do comando pra instalação do Zram, continuou o erro, te mandei em tela.

          • http://www.ubuntubrsc.com/ Julian Fernandes

            Olá @3ca2371bb544089b3355880cd606b22c:disqus, desculpe a demora. De cabeça consigo pensar em mais duas tentativas de solução.

            A primeira seria fazer os procedimentos descritos nesse post: http://www.ubuntubrsc.com/resolvendo-problema-zram-ubuntu-11-10.html
            Apesar do erro ser diferente, um usuário reportou o mesmo problema que o seu e deu certo.

            Outra possível solução seria fazer o download do arquivo .deb diretamente do Launchpad: https://launchpad.net/~shnatsel/+archive/zram/+files/zramswap-enabler_0.2.1-0~12~oneiric1_all.deb

            Pra instalar um arquivo .deb, basta dar dois cliques nele e depois clicar em “Instalar” (:

          • Almeidaufpb

             Ô Querido, muito obrigada pela atenção mas não deu certo. Ele está como instalado mas não consigo abrir a interface. Talvez, como sou nova no Ubuntu, eu esteja fazendo algo errado…

            Boa Páscoa pra vc e família!!

            Fabiana

          • http://www.ubuntubrsc.com/ Julian Fernandes

            Estranho @3ca2371bb544089b3355880cd606b22c:disqus,
            Bom, o Ubuntu 12.04 está quase ai e já temos uma melhoria de performance incrível.

            Feliz páscoa atrasada btw :)

          • Marcos Cezar

            Eu removi, adicionei o ppa novamente e instalei novamente e funcionou!

  • http://www.ubuntubrsc.com/ Julian Fernandes

    Olá @3ca2371bb544089b3355880cd606b22c:disqus,
    Tente rodar o seguinte comando: apt-get autoclean && apt-get clean
    Nunca tive esse erro, mas pelo o que andei vendo em uma pesquisa aqui, acontece quando a partição do sistema está cheia. Tente rodar o comando que lhe falei e usar o tutorial novamente (:

    • Almeidaufpb

       Olá Julian boa noite,
      obrigada pela ajuda.
      O resultado desse comando foi esse

      “fabiana@fabiana-O-E-M:~$ apt-get autoclean && apt-get clean
      E: Não foi possível abrir arquivo de trava /var/cache/apt/archives/lock – open (13: Permissão negada)
      E: Impossível criar trava no diretório de download
      fabiana@fabiana-O-E-M:~$ ”

      Fiz o procedimento do tutorial e acho que deu errado também. Anexei a captura da tela pra vc ver!

      Obrigada!

      • http://www.ubuntubrsc.com/ Julian Fernandes

        Olá @3ca2371bb544089b3355880cd606b22c:disqus,
        Desculpe, no comando que lhe passei esqueci de adicionar o sudo. Então fica assim:

        sudo apt-get autoclean && sudo apt-get clean

        • Almeidaufpb

           Opa!! Valeu.
          No 1º comando deu isso

          fabiana@fabiana-O-E-M:~$ sudo apt-get autoclean && sudo apt-get clean
          [sudo] password for fabiana:
          Lendo listas de pacotes… Pronto
          Construindo árvore de dependências      
          Lendo informação de estado… Pronto

          Depois do comando pra instalação do Zram, continuou o erro, te mandei em tela.

          • http://www.ubuntubrsc.com/ Julian Fernandes

            Olá @3ca2371bb544089b3355880cd606b22c:disqus, desculpe a demora. De cabeça consigo pensar em mais duas tentativas de solução.

            A primeira seria fazer os procedimentos descritos nesse post: http://www.ubuntubrsc.com/resolvendo-problema-zram-ubuntu-11-10.html
            Apesar do erro ser diferente, um usuário reportou o mesmo problema que o seu e deu certo.

            Outra possível solução seria fazer o download do arquivo .deb diretamente do Launchpad: https://launchpad.net/~shnatsel/+archive/zram/+files/zramswap-enabler_0.2.1-0~12~oneiric1_all.deb

            Pra instalar um arquivo .deb, basta dar dois cliques nele e depois clicar em “Instalar” (:

          • Almeidaufpb

             Ô Querido, muito obrigada pela atenção mas não deu certo. Ele está como instalado mas não consigo abrir a interface. Talvez, como sou nova no Ubuntu, eu esteja fazendo algo errado…

            Boa Páscoa pra vc e família!!

            Fabiana

          • http://www.ubuntubrsc.com/ Julian Fernandes

            Estranho @3ca2371bb544089b3355880cd606b22c:disqus,
            Bom, o Ubuntu 12.04 está quase ai e já temos uma melhoria de performance incrível.

            Feliz páscoa atrasada btw :)

  • kurosaki ichigo

    E se eu quizer desligar o zram como faço isso?

    • http://www.ubuntubrsc.com/ Julian Fernandes

      @uyJAjrjqOv:disqus só desinstalar o pacote dele :)

  • kurosaki ichigo

    E se eu quizer desligar o zram como faço isso?

    • http://www.ubuntubrsc.com/ Julian Fernandes

      @uyJAjrjqOv:disqus só desinstalar o pacote dele :)

  • kurosaki ichigo

    E se eu quizer desligar o zram como faço isso?

    • Rodrigo

      como verificar se esta funcionando? rodeio o sysv-rc-conf, ele aparece la, mas nao ta marcado em nenhum runlevel, é assim mesmo, ou deveria ta marcado algum?

    • http://www.ubuntubrsc.com/ Julian Fernandes

      @uyJAjrjqOv:disqus só desinstalar o pacote dele :)

  • Rodrigo

    como verificar se esta funcionando? rodeio o sysv-rc-conf, ele aparece la, mas nao ta marcado em nenhum runlevel, é assim mesmo, ou deveria ta marcado algum?

  • Rodrigo

    como verificar se esta funcionando? rodeio o sysv-rc-conf, ele aparece la, mas nao ta marcado em nenhum runlevel, é assim mesmo, ou deveria ta marcado algum?

  • Marcos Cezar

    Eu removi, adicionei o ppa novamente e instalei novamente e funcionou!

  • JoseRenan

    Instalei o zRAM e realmente melhorou a performance do Ubuntu! Obrigado pela dica! :D

  • JoseRenan

    Instalei o zRAM e realmente melhorou a performance do Ubuntu! Obrigado pela dica! :D

  • Diogo

    Obrigado por compartilhar do seus conhecimento para conosco…funcionou, tive um ganho de performance considerável.

  • Diogo

    Obrigado por compartilhar do seus conhecimento para conosco…funcionou, tive um ganho de performance considerável.

  • Igor Morais Azevedo

    Boa noite pessoal!

    Caso alguém que tenha instalado o zRam numa máquina que foi instalada com partição de swap ativa (que foi o meu caso), lembrem-se de desativá-la:
    # swapoff [localização completa da partição swap]
    # vim /etc/fstab {comentar a linha de montagem da partição de swap no boot}

    Agora você verá o zRam em ação!

  • Igor Morais Azevedo

    Boa noite pessoal!

    Caso alguém que tenha instalado o zRam numa máquina que foi instalada com partição de swap ativa (que foi o meu caso), lembrem-se de desativá-la:
    # swapoff [localização completa da partição swap]
    # vim /etc/fstab {comentar a linha de montagem da partição de swap no boot}

    Agora você verá o zRam em ação!

  • Marcelo Fermanian

    seguindo os conselhos, do site, para melhorar performance do Ubuntu 12.04.1LTS – 32 bits, primeiro atualizei o kernel para 3.4.0-030400-generic-pae, agora quando vou instalar o zRam, ele dar erro. Tentei tudo oq vcs tentaram e nada deu certo para instalar o pacote. Então desinstalei tudo, fiz uma limpeza geral e vou ficar no aguardo para vê o q acontece!!! Talvez uma atualização do pacote…

  • Marcelo Fermanian

    seguindo os conselhos, do site, para melhorar performance do Ubuntu 12.04.1LTS – 32 bits, primeiro atualizei o kernel para 3.4.0-030400-generic-pae, agora quando vou instalar o zRam, ele dar erro. Tentei tudo oq vcs tentaram e nada deu certo para instalar o pacote. Então desinstalei tudo, fiz uma limpeza geral e vou ficar no aguardo para vê o q acontece!!! Talvez uma atualização do pacote…

  • Renan Galvão

    Chupa Ram rápido! O sistema parece gerenciar muito melhor!! Instala porque vale muito a pena!

  • Ewertom

    Eu instalei mas como faço pra abrir a interface do mesmo?

  • Marcos Yoshihiro Nakamine

    No Ubuntu 12.04 com kernel 3.5 funcionou perfeitamente. Valeu pela dica.